Utilizando a função SOMASE

Algumas funções mais específicas do Excel estão começando a ser exigidas pelas bancas de alguns concursos. Recentemente foi formulada uma questão utilizando a função SOMASE.

O SOMASE trata-se de uma função de soma condicionada. Para entender como funciona a função SE clique aqui.

Vamos reconhecer a anatomia desta função:

=SOMASE(intervalo;critérios;intervalo_soma)

  • “=” Significa a chamada para uma fórmula/função
  • “SOMASE” Chamada para a fórmula SOMASE
  • “intervalo” Intervalo de células onde será feita a análise dos dados
  • “critérios” Critérios a serem avaliados nas células do “intervalo”
  • “intervalo_soma” Intervalo de células onde ocorrerá a soma. Este intervalo corresponde aos valores dos dados do “intervalo”

Desta maneira podemos imaginar o seguinte exemplo prático:

Função SOMASE

Em uma lista de dados,na coluna A, no caso do exemplo frutas, temos a coluna B representando seu Valor/Kg. Queremos saber o valor somente das maçãs, na célula D11.

Aplicamos a função da seguinte maneira =SOMASE(C2:C8;”MAÇÔ;D2:D8). O Excel fará o seguinte: no intervalo C2:C8 temos os nomes de todas as frutas disponíveis, no intervalo D2:D8 temos o valor/kg destas frutas, logo a função solicita que todas as células do intervalo C2:C8 (das frutas) sejam analisadas pelo critério “maça”. Sendo assim as células que são “maçã” tem seus respectivos valores somados no intervalo D2:D8.

Concluindo, o Excel somou o valor de todas as “maçã” do “intervalo” de acordo com o “intervalo_soma”, retornando o resultado na célula onde foi gerada a função. O resultado de 16,5 coresponde à soma de todas as maçãs do “intervalo”.

Se não for especificado o “intervalo_soma” serão considerados os valores do “intervalo”, porém no nosso exemplo não seria possível, pois o “intervalo” somente contém texto.

Alguma dúvida? Comente!

27 ideias sobre “Utilizando a função SOMASE

  1. Caro, gostaria de puxar para uma coluna textos ou datas de outras planilhas que obedeçam uma condição sem que crie espaços quando for falso, exemplo: Planilha 1: Planilha 2 Planilha 3
    data número data número data número
    01/01/14 1 01/01/14 2 puxa apenas data
    01/01/14 2 01/01/14 1 daqueles que possuem 1
    das planilhas 1 e 2.
    Como se fosse um somases, sem espaços falsos entre linhas na plan 3.
    Como faço?
    Obrigado.